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1 Общие сведения

В данном документе описан процесс сборки из исходных кодов демонстрационного приложения веб-
сервера, предназначенного для запуска на модуле SAMC-403.

Собранное демонстрационное приложение возможно запустить на модуле SAMC-403 различными спосо-
бами:

• загрузка по сети с TFTP сервера;
• загрузка с встроенной NAND флеш памяти;
• загрузка с встроенной NOR флеш памяти.

Загрузка приложения с встроенной EEPROM памяти невозможна из-за большого объема (около 4 Мбайт)
собранного приложения.

При загрузке демонстрационного приложения веб-сервера в EEPROM модуля должен быть записан за-
грузчик IBL (Intermediate Boot Loader), который выполняет загрузку приложения с TFTP сервера, с NAND
памяти или с NOR флеш памяти в зависимости от положения конфигурационных переключателей на мо-
дуле SAMC-403 (см. приложение А).

Для сборки демонстрационного приложения веб-сервера потребуется установленная система разработки
CCS (Code Composer Studio). Сборка демонстрационного приложения веб-сервера была проверена наCCS
версии 5.2.0.00069 под Windows систему. Дистрибутив CCS версии 5.2.0.00069 для Windows и Linux систем
можно найти на сопроводительном диске к модулю SAMC-403 в папке «software/ccs».

Демонстрационное приложение веб-сервера написано на основе кода демонстрационного примера из со-
става библиотеки TI MCSDK (MultiCore Software Development Kit) для процессоров C6678.
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2 Сборка проекта веб-сервера

Для сборки проекта демонстрационного веб-сервера необходимо установить среду разработки TI CCS и
библиотеку TI MCSDK. Сборка проекта проверялась с использованием среды разработки CCS версии
5.2.0.00069 и библиотеки MCSDK версии 2.00.08.20. Дистрибутив среды разработки CCS имеется на сопро-
водительном диске к модулю SAMC-403 в папке «software/ccs». Дистрибутив библиотеки MCSDK находится
на сопроводительном диске к модулю SAMC-403 в папке «software/ccs/mcsdk».

Исходный код проекта демонстрационного веб-сервера расположен на сопроводительном диске в папке
«hpdspua/src». В папке «hpdspua/bin» имеются предварительно собранные бинарные файлы демонстраци-
онной программы веб-сервера, которые можно использовать для запуска на модуле SAMC-403. Процедура
записи образов демонстрационного веб-сервера во встроенную флеш память подробно описана в разде-
ле 3. Процедура загрузки программы по сети с TFTP сервера и загрузка программы со встроенной флеш
памяти описывается в разделе 3.

Для сборки проекта в CCS необходимо импортировать проект в среду разработки и выполнить его сборку.

Для удобства работы с проектом демонстрационной программы веб сервера рекомендуется создать новое
рабочее пространство (workspace) в среде разработки CCS.

2.1 Создание рабочего пространства
Для создания нового рабочего пространства в среде разработки CCS выберите пункт меню
«File > Switch Workspace > Other...» (рисунок 2-1).

Рисунок 2-1: Смена рабочего пространства (workspace) в CCS
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В открывшемся окне (рисунок 2-2) выберите папку нового рабочего пространства. Например, можно исполь-
зовать папку «D:/SAMC-403/Workspace_Web».

Рисунок 2-2: Выбор папки для рабочего пространства (workspace) в CCS

Нажмите на кнопку «OK». Среда CCS будет перезапущена с новым рабочим пространством. После запуска
можно будет увидеть окно, аналогичное показанному на рисунке 2-3.

Рисунок 2-3: Главное окно среды CCS после запуска в новом рабочем пространстве
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2.2 Импорт проекта
Перепишите файлы проекта демонстрационной программы веб-сервера с сопроводительного диска к мо-
дулю SAMC-403 на жесткий диск компьютера. Исходные коды проекта можно найти на сопроводитель-
ном диске к модулю SAMC-403 в папке «hpdspua/src». Далее, предполагается, что содержимое папки
проекта «hpdspua/src» с сопроводительного диска была переписана на жесткий диск компьютера в папку
«D:/hpdspua».

Нажмите на кнопку «Import Project» (на рисунке 2-3 выделено красным овалом). Откроется окно, показанное
на рисунке 2-4.

Рисунок 2-4: Окно импорта проекта

Примечание

Окно импорта проектов, показанное на рисунке 2-4, можно вызвать через главное меню, выбрав пункт «File > Import...». В
открывшемся окне выбора типа проекта, нужно выбрать тип «Code Composer Studio > Existing CCS Eclipse rojects» и нажать
на кнопку «Next > ».

Нажмите на кнопку «Browse...». Откроется стандартное системное окно обзора папок файловой системы
(рисунок 2-5), в котором необходимо выбрать папку импортируемого проекта. В нашем случае, это должна
быть папка «D:/hpdspua». После выбора нужной папки, нажмите кнопку «OK».
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Рисунок 2-5: Системное окно выбора папок файловой системы

Если папка с проектом выбрана верно, в окне импорта проекта должен появиться проект «hua_-
evmc6678l» в списке проектов, доступных для импорта (рисунок 2-6). Снимите флажок с параметра
«Copy projects into workspace» (если он установлен) и нажмите кнопку «Finish».

Рисунок 2-6: Окно импорта проекта
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2.3 Сборка проекта
В левой части главного окна находится окно «Project Explorer», в котором должен находиться только один
проект «hua_evmc6678l». Нажмите правой кнопкой мыши на названии проекта и в появившемся меню вы-
берите пункт «Build Project» (рисунок 2-7).

Рисунок 2-7: Пункт меню для сборки проекта

Примечание

Если окно «Project Explorer» не появилось, его можно открыть, выбрав пункт меню «View > Project Explorer».

Примечание

Сборку проекта можно выполнить путем выбора пункта главного меню «Project > Build Project».

Будет запущен процесс сборки проекта, ход которого будет отображаться в окне, показанном на рисунке 2-8.
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Рисунок 2-8: Окно, отображающее ход процесса сборки проекта

В случае успешной сборки, в окне консоли (Console) должны быть выведены сообщения, идентичные пока-
занным на рисунке 2-9.

Примечание

Если окна консоли нету, его можно открыть, выбрав пункт меню «View > Console».

Рисунок 2-9: Окно, отображающее ход процесса сборки проекта

После выполнения сборки проекта в папке «D:/hpdspua/Debug» будет находиться файл «hua_-
evmc6678l.out». Этот файл является собранным бинарным файлом программы демонстрационного веб-
сервера, который можно загружать на модуле SAMC-403 одним из трех способов, которые подробно опи-
саны в разделе 3.

Примечание

В случае сборки проекта в конфигурации Release файл готового образа будет расположен в папке «D:/hpdspua/Release».

Выбор активной конфигурации сборки выполняется через пункт меню «Project > Build Configurations > Set Active». По
умолчанию, активной конфигурацией является конфигурация Debug.
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3 Загрузка программы веб-сервера

Для загрузки образа демонстрационного приложения веб-сервера используется загрузчик IBL, который дол-
жен быть правильно сконфигурирован и записан в EEPROM память на I2C шине по адресу 0x51 на модуле
SAMC-403.

Подробная информация по сборке, конфигурированию и записи загрузчика IBL в EEPROM модуля
SAMC-403 приведена в документе [1].

Так как проект демонстрационной программы веб-сервера собирается в формате ELF, загрузчик IBL должен
быть сконфигурирован со следующими параметрами:

• для загрузки с NOR флеш памяти:
ibl.bootModes[0].u.norBoot.bootFormat = ibl_BOOT_FORMAT_ELF;

• для загрузки с NAND флеш памяти:
ibl.bootModes[1].u.nandBoot.bootFormat = ibl_BOOT_FORMAT_ELF;

• для загрузки по сети с TFTP сервера:
ibl.bootModes[2].u.ethBoot.bootFormat = ibl_BOOT_FORMAT_ELF;;

Примечание

Для режима загрузки по сети с TFTP сервера допускается использование формата загрузки ibl_BOOT_FORMAT_NAME (по
умолчанию). В этом случае, файл образа на TFTP сервере должен иметь расширение «.elf» для правильной загрузки, так
как реальный формат образа определяется по расширению файла для загрузки.

3.1 Загрузка по сети с TFTP сервера
Для выполнения загрузки приложения на модуль SAMC-403 по сети с TFTP сервера необходимо наличие
в локальной сети BOOTP и TFTP серверов.

Примечание

Информация по установке и настройке BOOTP и TFTP серверов в Windows и Linux системах приведена в документе [2].

Для загрузки приложения на модуле SAMC-403 по сети перепишите собраный файл образа демонстрацион-
ного приложения веб-сервера в корневую папку TFTP сервера. Сконфигурируйте BOOTP сервер (см. доку-
мент [2]) на отдачу в качестве имени файла загрузки имя файла собранного образа в виде относительного
пути относительно корневой папки TFTP сервера.

Внимание

Если загрузчик IBL сконфигурирован на формат загрузки ibl_BOOT_FORMAT_NAME для режима загрузки по
сети, то переписываемому файлу образа демонстрационного приложения веб-сервера необходимо дать
расширение «.elf». То есть переименовать файл «hua_evm6678l.out» в «hua_evm6678l.elf».

После завершения конфигурирования BOOTP и TFTP серверов необходимо установить значение переклю-
чателей на модуле SAMC-403 в соответствии с таблицей A.4 (приложение A) и перезагрузить модуль.
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3.2 Загрузка c NAND-флеш памяти
Для возможности загрузки приложения демонстрационного веб-сервера с NAND флеш памяти, его необ-
ходимо туда записать. Перед выполнением записи, необходимо обновить GEL файл конфигурации
«evmc6678l.gel» модуля SAMC-403 для CCS, который имеется на сопроводительном диске к модулю в
папке «ibl/program_evm/gel».

Для обновления GEL файла конфигурации, выполните действия, описанные в процедуре 3-1.

Процедура 3-1. Обновление GEL файла конфигурации CCS

1. В последующих шагах предполагается, что CCS установлена в папку «<CCS_INSTALL_DIR»>
(обычно это «C:/Program Files/Texas Instruments/ccsv5» для Windows систем).

2. Закройте Code Composer Studio, если она открыта.
3. Замените существующий файл «evmc6678l.gel» в папке

«<CCS_INSTALL_DIR>/ccs_base/emulation/boards/evmc6678l/gel» на файл «evmc6678l.gel» с
сопроводительного диска к модулю SAMC-403.

Для записи образа приложения в NAND флеш память рекомендуется использовать утилиту program_evm,
которая имеется на сопроводительном диске к модулю SAMC-403 в папке «ibl/program_evm».

Перед выполнением записи образа в NAND флеш память перепишите папку «ibl/program_evm» с сопрово-
дительного диска на жесткий диск компьютера (например, в папку «D:/program_evm»).

Примечание

Далее предполагается, что папка «ibl/program_evm» переписана с сопроводительного диска в папку «D:/program_evm».

Шаги, необходимые для выполнения записи образа в NAND флеш память модуля SAMC-403 описаны в
процедуре 3-2.

Процедура 3-2. Запись образа в NAND-флеш память на модуль SAMC-403

1. Перепишите собранный образ демонстрационного приложения веб-сервера
(«hua_evmc6678l.out») из папки проекта («D:/hpdspua/Debug» или «D:/hpdspua/Release») в папку
«D:/program_evm/binaries/evm6678l» и переименуйте его в «nand.bin».

2. На выключенном модуле SAMC-403 установите переключатели в соответствии с таблицой А-1 (см.
приложение А).

3. Установите правильное значение переменной окружения DSS_SCRIPT_DIR. Если CCS
установлена в папку «C:/Program Files (x86)/Texas Instruments/ccsv5», то переменной
DSS_SCRIPT_DIR должно быть присвоено значение «C:/Program Files (x86)/Texas
Instruments/ccsv5/ccs_base/scripting/bin». Сделать это можно выполнив команду:

set DSS_SCRIPT_DIR="C:\Program Files (x86)\Texas Instruments\ccsv5\ccs_base\scripting\bin"

4. Включите модуль SAMC-403 и дождитесь инициализации эмулятора и завершения USB
инициализации (около 10 секунд для XDS100 эмулятора и около 45 секунд для XDS560
эмулятора).

5. Запустите утилиту program_evm для записи образа приложения в NAND флеш память:
cd D:/program_evm
%DSS_SCRIPT_DIR%\dss.bat program_evm.js TMDSEVMC6678L-le "nand"

6. Выключите модуль SAMC-403 и установите переключатели в положение соответствующее
загрузке модуля с NAND флеш памяти (таблица А-2, приложение А).

При запуске утилиты program_evm для записи содержимого NAND-флеш памяти (на это указывает пара-
метр командной строки «nand»), будет записываться файл «D:/program_evm/binaries/evm6678l/nand.bin».
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Имя данного файла считывается утилитой program_evm из файла «D:/program_evm/binaries/nand_writer_-
input.txt». По умолчанию, содержимое этого файла имеет следующий вид:

file_name = nand.bin
start_addr = 16384
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3.3 Загрузка c NOR-флеш памяти
Для записи образов в NOR флеш память, используется та же утилита program_evm, работа с которой опи-
сана в разделе 3.2 для записи образа приложения в NAND флеш память. Отличие заключается только в
параметре командной строки утилиты program_evm при запуске.

При запуске утилиты program_evm для записи содержимого NOR флеш памяти (на это указывает параметр
командной строки «nor»), будет записываться файл «D:program_evm/binaries/evm6678l/nor.bin».

Имя данного файла считывается утилитой program_evm из файла «D:/program_evm/binaries/ nor_writer_-
input.txt». По умолчанию, содержимое этого файла имеет следующий вид:

file_name = nor.bin
start_addr = 0

Таким образом, шаги необходимые для записи образа приложения в NOR-флеш память приведены в про-
цедуре 3-3:

Процедура 3-3. Запись образа в NOR-флеш память на модуль SAMC-403

1. Перепишите собранный образ демонстрационного приложения веб-сервера
(«hua_evmc6678l.out») из папки проекта («D:/hpdspua/Debug» или «D:/hpdspua/Release») в папку
«D:/program_evm/binaries/evm6678l» и переименуйте его в «nor.bin».

2. На выключенном модуле SAMC-403 установите переключатели в соответствии с таблицой А-1
(см. приложение А).

3. Установите правильное значение переменной окружения DSS_SCRIPT_DIR. Если CCS
установлена в папку «C:/Program Files (x86)/Texas Instruments/ccsv5», то переменной
DSS_SCRIPT_DIR должно быть присвоено значение «C:/Program Files (x86)/Texas
Instruments/ccsv5/ccs_base/scripting/bin». Сделать это можно выполнив команду:

set DSS_SCRIPT_DIR="C:\Program Files (x86)\Texas Instruments\ccsv5\ccs_base\scripting\bin"

4. Включите модуль SAMC-403 и дождитесь инициализации эмулятора и завершения USB
инициализации (около 10 секунд для XDS100 эмулятора и около 45 секунд для XDS560
эмулятора).

5. Запустите утилиту program_evm для записи образа приложения в NAND флеш память:
cd D:/program_evm
%DSS_SCRIPT_DIR%\dss.bat program_evm.js TMDSEVMC6678L-le "nor"

6. Выключите модуль SAMC-403 и установите переключатели в положение соответствующее
загрузке модуля с NAND флеш памяти (таблица А-3, приложение А).
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4 Запуск программы веб-сервера

После выполнения шагов, описанных в разделах 2 и 3, при включении модуля SAMC-403 произойдет за-
грузка демонстрационного приложения веб-сервера.

Доступ к приложению осуществляется по IP-адресу, который может быть выдан динамически DHCP сер-
вером или задаваться фиксированно с помощью соответствующей настройки DHCP сервера (см. доку-
мент [2]).

Для доступа к приложению веб-сервера может быть использован любой интернет-браузер (например,
Mozilla Firefox). Запустите браузер и введите в адресной строке IP-адрес модуля, будет загружена главная
страница демонстрационного приложения веб-сервера (рисунок 4-1).

Рисунок 4-1: Главная страница демонстрационного приложения веб-сервера

www.setdsp.ru 17 / 19

www.setdsp.ru


SAMC-403. Сборка и запуск приложения веб-сервера UG-SAMC-403-WEB

Приложение А Аппаратная конфигурация

При загрузке и отладке приложения напрямую через JTAG, без использования загрузчика IBL, положение
переключателей на модуле SAMC-403 необходимо установить в соответствии с таблицей А-1.

Таблица А-1: Положение переключателей для программирования модуля SAMC-403

Переключатель 1 2 3 4
SW3 OFF ON ON ON

SW4 ON ON ON ON

SW5 ON ON ON ON

SW6 ON ON ON ON

Для загрузки приложения с NAND флеш памяти, положение переключателей на модуле SAMC-403 необхо-
димо установить в соответствии с таблицей А-2.

Таблица А-2: Положение переключателей для загрузки модуля SAMC-403 с NAND-флеш памяти

Переключатель 1 2 3 4
SW3 OFF OFF ON OFF

SW4 ON OFF ON ON

SW5 ON ON ON OFF

SW6 ON ON ON ON

Для загрузки приложения с NOR флеш памяти, положение переключателей на модуле SAMC-403 необхо-
димо установить в соответствии с таблицей А-3.

Таблица А-3: Положение переключателей для загрузки модуля SAMC-403 с NOR-флеш памяти

Переключатель 1 2 3 4
SW3 OFF OFF ON OFF

SW4 ON ON ON ON

SW5 ON ON ON OFF

SW6 ON ON ON ON

Для загрузки приложения с TFTP сервера, положение переключателей на модуле SAMC-403 необходимо
установить в соответствии с таблицей А-4.

Таблица А-4: Положение переключателей для загрузки модуля SAMC-403 с TFTP-сервера

Переключатель 1 2 3 4
SW3 OFF OFF ON OFF

SW4 ON ON OFF ON

SW5 ON ON ON OFF

SW6 ON ON ON ON
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